Fix Python – Where do I find the bashrc file on Mac?

Hello I am following this page.. I’m installing Python onto my mac so that I can set up a Django / Eclipse development environment. However I am not too sure how to go about executing this step:

The script will explain what changes it will make and prompt you
before the installation begins.

Once you’ve installed Homebrew,
insert the Homebrew ….

Fix Python – How to reinstall python@2 from Homebrew?

I have been having issues with openssl and python@2 with brew, which have explained here (unresolved). The documented workaround to reinstall Python and openssl was not working, so I decided I would uninstall and reinstall Python.
The problem is, when you try to install Python 2 with brew, you receive this message:
brew install python@2
Error: No ….

Fix Python – How can I install a previous version of Python 3 in macOS using homebrew?

How can I install a previous version of Python 3 in macOS using brew?
With the command brew install python I got the latest version of Python 3 (currently v3.7.0), but I want the last version of Python 3.6 (currently 3.6.5).
I have read about another package pyenv that can assist in handle different python installation, but this solution is not su….

Fix Python – “ERROR:root:code for hash md5 was not found” when using any hg mercurial commands

When trying to use any hg Mercurial commands on the console, I keep getting this error.
I installed Python using Homebrew and I am running Mac OS Catalina v. 10.15.1.
Any reference would be appreciated. Here is the error I’m getting:
hg commit –amend
ERROR:root:code for hash md5 was not found.
Traceback (most recent call last):
File “/usr/loca….

Fix Python – Broken references in Virtualenvs

I recently installed a bunch of dotfiles on my Mac along with some other applications (I changed to iTerm instead of Terminal, and Sublime as my default text editor) but ever since, all my virtual environments have stopped working, although their folders inside .virtualenvs are still there and they give the following error whenever I try to run an….